Latest interface: 0.3.1
Latest system: 010

11 posts

Posted on 31 October 2014 @ 20:54edited 20:54 31s
To speed up the nas I bought a Plextor M6e SSD (PCI-e). Somehow ZFSguru does not seem to recognize it though FreeBSD should support it. Any ideas or should this be moved to feature request?

1199 posts

Posted on 31 October 2014 @ 21:13
Can you provide me with the 'dmesg' and device node listing?

On the command line, provide the output of:

1) dmesg
2) ls /dev

11 posts

Posted on 31 October 2014 @ 23:09
I put it in a HP N54L. To be complete the ahci1 is the onboard controller which is populated fine with the 5 disks (ada0 - ada4) and of course there's the usb da0 which runs the ZFSguru distribution. I can't see any additional devices in the /dev/ so I pasted the whole entry. md99 is a swap partition on the zfs volume to keep the services from killing themselves running out of memory.
The running system:
Powered by ZFSguru version 0.2.0-beta9
Running official system image 10.1-001 featuring FreeBSD 10.0-STABLE with ZFS v5000.
Running Root-on-ZFS distribution.

ahci0: <AHCI SATA controller> port 0xe800-0xe807,0xe400-0xe403,0xe000-0xe007,0xd800-0xd803,0xd400-0xd41f mem 0xfe8ffc00-0xfe8ffdff irq 18 at device 0.0 on pci2
ahci0: AHCI v1.00 with 1 6Gbps ports, Port Multiplier not supported
ahcich0: <AHCI channel> at channel 0 on ahci0

[root@zfsguru ~]# ls /dev/
acpi da0 kmem pci ttyv4 ugen3.2@
ada0 da0p1 log@ pf ttyv5 ugen4.1@
ada1 da0p2 md99 pts/ ttyv6 ugen5.1@
ada2 devctl mdctl random ttyv7 uhid0
ada3 devstat mem rdma_cm* ttyv8 ukbd0
ada4 fd/ midistat sndstat ttyv9 urandom@
apm fido nfslock stderr@ ttyva usb/
apmctl geom.ctl null stdin@ ttyvb usbctl
audit gpt/ pass0 stdout@ ufssuspend xpt0
bpf io pass1 sysmouse ugen0.1@ zero
bpf0@ kbd1@ pass2 ttyv0 ugen0.2@ zfs
console kbd2@ pass3 ttyv1 ugen1.1@
consolectl kbdmux0 pass4 ttyv2 ugen2.1@
ctty klog pass5 ttyv3 ugen3.1@

and the pciconf output:
ahci0@pci0:2:0:0: class=0x010601 card=0x91831b4b chip=0x01221c28 rev=0x14 hdr=0x00
class = mass storage
subclass = SATA

camcontrol rescan returns
(aprobe0:ahcich0:0:0:0): Unexpected signature 0xffff
in the system log

1199 posts

Posted on 1 November 2014 @ 11:51
According to this SSD is not supported by FreeBSD until sometime in October.

You can try upgrading to the 10.1-002 system image released on 7 October, hopefully it will have the fix and recognise your drive properly.

11 posts

Posted on 2 November 2014 @ 03:42
Sadly 10.1-002 will not boot. It dumps me right after the kernel telling me the bootlabel can't be found. Entering the bootlabel exactly as it tells where it could not be found continues the boot. Only after setting the hostuuid and hostid the system stops responding.
10.0, 10.1-001 and 11.0-002 boot fine though lack the pcie ssd support I am hoping for.

1199 posts

Posted on 2 November 2014 @ 10:54
Have you tried 11.0-003? It has no services, but it may have the fix for your SSD. You can at least try.

Also, have you tried to install 10.1-002 again? Maybe something went wrong the first time. If not, can you give me the *exact* message being displayed? A picture of the boot screen is also helpful.

11 posts

Posted on 2 November 2014 @ 19:36
Yay! 11.0-003 did the trick. All disks where moved up and ada0 showed up as the new 128G Plextor SSD. After upgrading to 0.2.0-beta10 and a manual import from the console the pools where visible again.
I was unable to add the device as cache device to the pool from the web interface.
Pools, Cache devices, selecting "pool0" as the pool to add the cache returned:
"Warning: pool pool0 can not be used, because the pool is !"
Manually adding the device with
[root@zfsguru ~]# zpool add pool0 cache ada0
eventually did the trick.

If I can help by adding more info let me know.

Out of the scope of this thread but maybe interesting is that on 11.0 mountd doesn't seem to start at boot. Only a restart of nfsd fixes the nfs connections.
As far as 10.1-002 is concerned I think it was a faulty usb stick.

Thanks for the support so far.

2 posts

Posted on 19 January 2019 @ 04:49
Support is the first step towards client satisfaction which you can think and do for them. The custom essay writing services australia share further things which you can do for your clients.

10 posts

Posted on 3 February 2019 @ 08:12
Support is a way to make your client more secure and regular for you. The also give support now a day.
Last Page

Valid XHTML 1.1