Latest interface: 0.3.1
Latest system: 010
karmantyu
User

131 posts

Posted on 3 May 2017 @ 20:24edited 4 May 2017 @ 20:20
This should be a sort explanation for those people who may have upgraded their system's packages for some reason and would like to have working Samba and WEB interface too.

If you do
# pkg upgrade
- which I strongly encourage you to do for some obvious security reasons - after package upgrade you will promptly lose web interface access. To repair this SSH in your server and as su type
# chown -R 888:888 /var/spool/lighttpd
# chown -R 888:888 /var/log/lighttpd
# service lighttpd restart
and you will have the web interface back.

Previously, Samba did not check the execution bit of files. As a consequence, users could execute files, such as when upgrading from a previous version, your executable files can be missing the x-bit.
So add please the following line to /usr/local/etc/smb.conf in the global section.
acl allow execute always = yes

The upgrade process most likely replaced your Samba3 with Samba4. To have working Samba you have to copy some files to new locations and edit rc.conf.
# cp /usr/local/etc/smb.conf /usr/local/etc/smb4.conf
# cp /usr/local/etc/samba/* /var/db/samba4/private/
Finally, in /etc/rc.conf replace samba_enable="YES" with samba_server_enable="YES".

After reboot you will have working Samba4 with the Samba3 presets. Remember that you can't start/stop samba service from the web interface system services page anymore. If you need this from a peculiar reason you can kill samba with # killall smbd
and can restart with # service samba_server onerestart
as superuser.

If you modify your samba setting on the web interface, you have to stop samba, copy the configuration files again (see above) and restart samba to kick in the changes.

Have fun :)
Last Page

Valid XHTML 1.1