Latest interface: 0.3.1
Latest system: 010
Hagabard
User

4 posts

Posted on 17 January 2016 @ 06:30
I had a mixed redundancy pool while I was waiting for my new 4TB drives to show up. (Two 500GB drives that were mirrored and a 2tb that was added as a stripe. Long story is I didn't have enough money to get enough drives to save my other failing server - so that's how I ended up there.

So first thing I do is drop in the new drive on the new server, and promptly add the 4TB to the pool, not as a mirror. Great, I just did standard boneheaded newbie mistake #1. Don't worry, I manage to do one better soon.

So I do my research, and the only option is to copy the data somewhere else, so I setup the other 4tb as 'newpool' and do a zfs send/receive. Everything was cool, but it wasn't bootable. I grabbed a ZFS guru boot disc, and was able to set the bootable stuff. And at this point, I add the other 4TB drive as a proper mirror, and the reslivering starts. Somehow when I rebooted back to the main system, the system decided I now had two pools, cave and newpool. They are identical pools, both are 4tb mirrored drives. I tried to import and export the pool to fix, but I couldn't figure it out. System was operating ok, pool was still reslivering, so I gave up on making it not look like there was two pools. I start copying data from another failing UFS drive to the pool and go to bed.

Now I don't know exactly what happened but overnight but I think it rebooted either due to power or erroring from the two pool thing going on. It won't boot because it crashed, and now it won't import the pool when I boot to CD. Both drives test out with no errors, so I am operating on the assumption the disks are ok. So, I have tried with one drive and with both, and can't get the pool to import. Right now, I have the incomplete drive removed from the system to try to force a detach and maybe get the first drive back online.

pool: tank
id: ########
state: FAULTED
status: One or more devices were being resilvered.
action: The pool cannot be imported due to damaged devices or data.
The pool may be active on another system, but can be imported using
the '-f' flag.
config:

tank FAULTED corrupted data
mirror-0 DEGRADED
gpt/new-1 ONLINE
################### UNAVAIL cannot open

When I try to do this, since the pool isn't actually up/online, it won't do so. At first I was getting:

[root@zfsguru ~]# zpool import tank
cannot import 'tank': I/O error
Destroy and re-create the pool from
a backup source.

After looking online, there are a bunch of crazy flags to try to go back in time to recover, several of which I didn't keep track of, but when I tried with or without both drives, this was as close as I got:

[root@zfsguru ~]# zpool import -F -X -R /mnt tank
cannot import 'tank': one or more devices is currently unavailable

How do I detach the 2nd drive from the mirror to see if it will come up?

I do sort of have the data of the 500GBs and the failing 2tb drive from the original, but since I added the 4TB, I think they are just as useless. Unless there is a way? I did do a @moving snapshot to do the send/receive, so I don't know if that will help anything on either end.

I have a pile of failing hard drives around me, and I can't loose any more data than I already have. I was hoping that getting a proper mirror setup would help me from loosing more, but so far I think I've managed to loose it all.

Is there any hope for my data? Any ZFS data recovery wizards about?

CiPHER
Developer

1199 posts

Posted on 4 February 2016 @ 21:26
Hi Hagabard,

Sorry for my late reply. Are you still in need for help?

I am not sure what happened to you, the details are somewhat vague. You had two identical pools using both disks; but that should be impossible that two pools are using the same disks, or did i misunderstood?

Either way, i also see you got an I/O error. You should try to identify whether the SMART data of your drives look good. There could be cabling errors and if so, this would be good news since the problems might be fixed by replacing them. But it is also possible the 'corrupted data' stays and in that case i fear for your data.

Please let me know if i can still be of help to you.
Hagabard
User

4 posts

Posted on 10 April 2016 @ 20:16
I have been busy since school started in Jan. I did take out one of the 4TBs (the one that never slivered fully) and reformatted for use as a single drive for now. The 2TB is going bad, so there may be nothing I can do about any of it.

The main problem that I brought upon myself was to try to rename the pool while booted to live cd and then booting back into the same system drive it decided that both existed with the same drives. Ooops. I have not given up 100% on the data but I am fairly certain I cannot access or save the pool drives with ZFS. I will have to resort to photorec to pull the data I want to save off the disk, and then I can properly add it back in properly to mirror this time :)
Allen37
User

5 posts

Posted on 19 February 2019 @ 13:40
We all do mistakes but that doesn't mean we can't do anything. The live me apk download provide us motivation.
Beren
User

2 posts

Posted on 17 March 2019 @ 15:15edited 15:15 41s
It has many useful concepts to understand and write about bestessays writers. They all receiving our useful concepts and supportive essay book guru projects.

Last Page

Valid XHTML 1.1