Latest interface: 0.3.1
Latest system: 010
mbcoyote
User

3 posts

Posted on 26 December 2015 @ 08:47
So I've run version 1.x and 2.0 experimental versions of the ZFS guru web interface for a few years on my FreeBSD system. I don't use ZFS guru to manage my system - rather I've always just used the interface to help in managing my ZFS pools (and am not really interested in root on ZFS).

While attempting to upgrade to the 3.1 release - I'm getting the above error when trying to use the web interface.

Manual install instructions I know are a bit out of date - and google is not my friend in this respect.

Running FreeBSD 10.2 - any help is appreciated.
CiPHER
Developer

1199 posts

Posted on 26 December 2015 @ 10:30edited 10:33 57s
Step 1. Create a user and group called 'zfsguru-web' with uid 888 and gid 888:

pw groupadd zfsguru-web -g 888
pw useradd zfsguru-web -u 888 -d /nonexistent -s /sbin/nologin

Step 2. Change /usr/local/etc/sudoers to allow zfsguru-web access instead of user 'www'.

ee /usr/local/etc/sudoers

Step 3. Now, let the webserver Lighttpd run with the new user by modifying /usr/local/www/lighttpd/lighttpd.conf, and replace the current 'www' user configuration with 'zfsguru-web' like this:

server.username = "zfsguru-web"
server.groupname = "zfsguru-web"


Step 4. Then you might need to change permissions to zfsguru-web for some directories:

chown -R 888:888 /var/spool/lighttpd
chown -R 888:888 /var/log/lighttpd

Step 5. Finally, start the webserver:

service lighttpd restart
mbcoyote
User

3 posts

Posted on 26 December 2015 @ 16:35
That did it. Thanks.

Initially I got the following errors. However, after clearing out my /tmp directory (where session save files were going) the error did not reappear.

Warning: session_start(): open(/tmp/sess_aebu77h2bl05djav4hlc0as7b1, O_RDWR) failed: Permission denied (13) in /usr/local/www/data/includes/procedure.php on line 12

Warning: Unknown: open(/tmp/sess_aebu77h2bl05djav4hlc0as7b1, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0
Goliath
User

2 posts

Posted on 6 August 2016 @ 11:28
CiPHER, and for those of us that don't run lighttpd and have Apache installed instead do you have any guidelines for us? Because I get also permission denied!
CiPHER
Developer

1199 posts

Posted on 27 August 2016 @ 20:53
For Apache the configuration is kept in /usr/local/etc/apache24/httpd.conf and the user account that Apache runs at is also contained therein.
Last Page

Valid XHTML 1.1