Latest interface: 0.3.1
Latest system: 010

806 posts

Posted on 11 August 2014 @ 14:21edited 14:27 11s
After working very hard for multiple months, the first fruits are ready for the harvest!

As announced in the State of the Project 2014, the automated system builds are becoming reality. This has been somewhat of a dream to me, since it frees up so much development time I would gladly spend on other tasks. While working on this automated system build architecture proved quite a challenge to my skills, it seems to be working rather nicely.

Therefore, today I can proudly announce the first system image produced by this new build system. At the moment I pressed the button, it took slightly less than two hours to create this image. The only manual intervention needed is to select the options for the software packages. But it remembers these for future builds, and only changes in these options will be presented.

Work in progress: no services yet!
However, the new build system is not complete yet. It cannot build the addon packages yet which are dubbed Services in ZFSguru jargon. This will be the next area of focus. Additionally, the GuruDB and automated upload functionality of the new build system is still in the works.

Call for testing
In the meantime, I would like to ask people interested in testing the new system image to provide me with feedback. Is everything working like it should? Any configuration files that might be missing? Due to the completely different way this image is built, there could be side effects which I am unaware of. While I work on completing the new build system, it would be nice if some of you could test whether it works properly.

Changes in the system image
This system is experimental not only because it was built using the new build system, but also because it was built from the 'head' branch of the underlying BSD operating system. This means it is dubbed 11-CURRENT, which in the future will become 11.0-RELEASE. This means it was drawn from the active development branch, where the latest code commits are submitted. Undiscovered bugs are always a possibility, so do not use for production machines!

Some of the known changes in this image:
  • Newcons/vt console driver has been improved. In VirtualBox it is still very slow, but on real machines it should be much better.
  • Improvements to the native iSCSI implementation.
  • Improvements to the new native hypervisor called bhyve.
  • Performance improvements related to ZFS, I/O subsystem and many more areas.

Warning: incompatible with beta9 web-interface!
During testing I found that there were changes in the way this new system image reports ZFS status, as well as changes in the disk formatting subsystem. The result is that using beta9 with the 11.0-002 system image, formatting disks will not create a boot partition as it should, and you get an error when trying to display pool details.

I made changes to the web-interface that should resolve these issues, and have release beta10 to mitigate the issues. Beta10 should work both with the new system image as well as older ones. Aside from the compatibility fixes, the only change is that the detailed pool view will hide messages about the pool having disabled features.

What is next?
I am very keen on resuming work on the web-interface, but I really should finish the system build system first. Being able to quickly produce new system images together with addon services is a major milestone for the project. In the meantime developer CiPHER is busy with the new master servers (alpha and bravo). Stay tuned for more updates! :-)

- Jason

164 posts

Posted on 14 August 2014 @ 08:51
Dear Jason,
It is always good to read that something new is happening - coming from Zfsguru.
I'am sorry I had very little time testing the new build. I've installed it and booted up but could not SSH in it so did not test it in depth. (Maybe my fault that SSH did not let me in , maybe something else - beta10?)
I suspect the spindown is still not fixed I mentioned here
and maybe other minor problem still existing but substantially the build works:)

Keep up the good work, thank you...

1199 posts

Posted on 14 August 2014 @ 11:22
Did you set a SSH password on the Access->OpenSSH page? You need to do that again after installing a new system image.

164 posts

Posted on 14 August 2014 @ 14:11
I may have been in a hurry and set only password fro the web interface. My fault.

164 posts

Posted on 20 August 2014 @ 11:19
I’ve tried to add services manually. GDM is a no go. Kernel may be compiled without driver support? Will there be an 11.0-002 version with services too?

1199 posts

Posted on 20 August 2014 @ 18:01
Kernel is a regular GENERIC kernel plus OFED infiniband, Device polling and AltQ - nothing special. Nothing different regarding 'drivers'. Keep in mind the 11-CURRENT branch is experimental and some ports may fail.

Jason is working on the new build system. 11.0-002 was the first result of this new build infrastructure. It can only produce system images without services at this point. Once Jason completes the new build system, new images with services will become available. A major milestone for the ZFSguru project. :)

19 posts

Posted on 21 August 2014 @ 14:42
CiPHER wrote: Kernel is a regular GENERIC kernel plus OFED infiniband, Device polling and AltQ - nothing special. Nothing different regarding 'drivers'. Keep in mind the 11-CURRENT branch is experimental and some ports may fail.
Are you modifying GENERIC in any other way?

I'm on 10.1-001 (amd64) and when I try to run rwhod(8) it fails and this shows up in /var/log/messages:

rwhod[44419]: The pdfork(2) system call is not available; recompile the kernel with options PROCDESC


1199 posts

Posted on 21 August 2014 @ 15:19
What ZFSguru does is include the GENERIC kernel, and add some options. So the kernel is the same as GENERIC, with some stuff added:
- Infiniband networking
- Device polling
- AltQ

Nothing is removed or modified. The only exception being that debugging stuff is removed from 11.x kernels.

Regarding PROCDESC, i found this thread:

I run 10.1-001 here too; and when i run 'rwhod -l' i do not get an error. Any way i can test what you do to produce that error?
Last Page

Valid XHTML 1.1