Latest interface: 0.3.1
Latest system: 010

11 posts

Posted on 1 October 2015 @ 21:29
What am I missing? [ZFSguru 10.2.002, interface 0.3.1]

Config NFS for remote access. I do create settings in webgui, however nothing is visible in /etc/exports?
Reload services, try to mount from remote -> it's working!

However I do have the wrong authorization. Try maproot -> does not work, it every time flags also mapall.
Cannot find NFS config. Would like to keep everything manageable via GUI..

1199 posts

Posted on 1 October 2015 @ 22:58
Could you explain in more detail what you did?

You reloaded what services? The NFS service?

With wrong authorization you mean maproot does not work? Do you mean it does not work on the web-interface or on the shell?

11 posts

Posted on 2 October 2015 @ 20:31
Sorry for the too short note:

1. create NFS via ZFSguru WebGUI: Access > tab NFS > new share
2. select file system to share, access profile public > Create new NFS share
3. if found my config in /etc/zfs/exports > shows: /livetank/rPi -alldirs -mapall=1000:1000
4. mount from RPi goes without errors, however: I've got no write permission
5. back in webGUI, select NFS > Advanced NFS configuration
6. de-flag mapall + flag maproot <parameter: root> + <enter> of <update NFS config>
7. go back to advanced config -> both parameters mapall and maproot are selected
8. when restarting service: SERVICE NFSD RESTART -> i see errors in /var/log/messages:
Oct 2 18:28:26 zfsguru mountd[639]: -mapall and -maproot mutually exclusive
Oct 2 18:28:26 zfsguru mountd[639]: bad exports list line /livetank/domoPi -alldirs -maproot

My initial question is solved: in /etc/zfs I'll find the exports file.
New question: how to solve my authorization?

1199 posts

Posted on 4 October 2015 @ 06:07
Hi aerrow5,

This pretty much explains it:

-mapall and -maproot mutually exclusive

You cannot use both the 'mapall' and 'maproot' parameters. You can only use either one, or none of them.

The mapall parameter will set ALL user uid to one number or name.

The maproot parameter will set the uid for root user, which normally is protected. Generally using 'maproot=root' will allow creating files as the root user using NFS shares, which is otherwise impossible.

So the solution would be to remove either one from your ZFS share configuration. I guess the ZFSguru web-interface should deny you from using both of them at the same time. I will consider this as a feature request.

11 posts

Posted on 7 October 2015 @ 20:29edited 8 October 2015 @ 08:20
I understood from previous posts that this isn't possible.
As I wrote down, at step 6, I let the GUI generate the right config, however -> in step 7 you see that the GUI shows both again flagged. So: the GUI created something illegal. It always flags the '-alldir' option.

Back to my authorization issue.
Edit /etc/zfs/exports:
/livetank/domoPi -alldirs -maproot=root

restart services: SERVICE NFSD RESTART

Tried to connect from my Debian (RPi), which results in error:
mount.nfs: access denied by server while mounting

Anybody any idea? Root should process everything?

11 posts

Posted on 10 October 2015 @ 19:25
Issue solved: restart another service: "service mounted restart" fixes my issue

1199 posts

Posted on 10 October 2015 @ 19:59
I think you mean 'mountd' ?

Did you try restarting the server before you fixed the issue? That should also have the same effect i think. 'mountd' is part of the NFS server, which consists of about 5 services (nfsd, mountd, rpcbind, lockd, statd). Restarting the system should also restart these services.

In /etc/rc.conf file these services are controlled by this section:

## NFS
# if you have problems, perhaps you can try the old NFS server:

That is all i know...
Last Page

Valid XHTML 1.1