Latest interface: 0.3.1
Latest system: 010
fbicknel
User

3 posts

Posted on 10 March 2019 @ 13:47
I just set up my new Ubuntu 18.04 system (I've run ZFS on Ubuntu 16.04 for a couple of years before).

Everything's working fine, but for some reason the zfs-auto-snapshot script is creating snapshots that are world-readable on all filesystems. If I make them more reasonable like 755, the next snapshot to come along is 777 again (but it doesn't change the ones I change back.)

I researched a bit and there appears to be an aclmode property, but when I run zfs get all <fs>, no such property falls out. Not even sure if this is important to the issue, though.

This didn't happen on 16.04.

Any ideas where to start looking here?

I just upgraded the zpool ... no mention of acl in the list of new capabilities and still no luck with the aclmode property.

oh.. there is aclinherit its set to 'restricted' by default.
The other mention is acltype set to 'off' by default.

I don't ever mess with acls, but here's how they are set up on this fs:

bick-ubtu3 /home/.zfs/snapshot$ sudo getfacl /home
getfacl: Removing leading '/' from absolute path names
# file: home
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

I did a diff on the zfs-auto-snapshot script and there's nothing in the 30 or so lines of differences that has anything to do with creating new snapshots. I am not even sure which property would govern that: acl the closest, but as I mentioned, there's no aclmode property even listed!

Thanks in advance....
JideJim
User

5 posts

Posted on 29 April 2019 @ 18:19
Thanks, fbicknel! Will bookmark this now.
Last Page

Valid XHTML 1.1